nix-conf/modules/home-manager/monitor/default.nix
2024-09-11 10:39:42 +05:30

32 lines
686 B
Nix

{
config,
inputs,
lib,
pkgs,
...
}: {
options = {
monitor.enable = lib.mkEnableOption "enable monitor";
};
config = lib.mkIf config.monitor.enable {
systemd.user.timers.monitor = {
Install.WantedBy = [ "timers.target" ];
Timer = {
OnBootSec = "1m";
OnUnitActiveSec = "1m";
Unit = "monitor.service";
};
};
systemd.user.services.monitor = {
Unit = {
Description = "A script to monitor websites.";
};
Install = {
WantedBy = [ "default.target" ];
};
Service = {
ExecStart = "${inputs.monitor.packages.${pkgs.system}.default}/bin/monitor";
};
};
};
}